WM61 Bluetooth Tethering Problems

Discussion in 'Moto Q 9h' started by kuruption, Aug 30, 2008.

  1. kuruption

    kuruption New Member

    Joined:
    Aug 29, 2008
    Messages:
    8
    Likes Received:
    0
    WM61 Bluetooth Tethering Problems

    Hey all,

    This week AT&T replaced my MotoQ due to various issues I was having with it, and they sent me one of the new, fancy silver ones with WM61 on it.

    With my old Q, I could only get the bluetooth internet access to work using the dial-up networking scripts, etc w/ my macbook pro (I have the tethering plan); I could never get the USB connection to work. With the new phone, I ran into a problem using the dial-up networking, so I started to investigate the Bluetooth PAN option.

    So basically, my problem is this. When I start the Internet Sharing program on the Q, select Bluetooth PAN, and click connect, it sits there and waits for a connection. On my MBP, I tell it to connect.... it does, I get an IP address, etc etc from the phone. I can ping the phone. I try to go to a website, nothing. So, I look at the phone, and I have an application error telling me im.exe ("An application error has occured in im.exe") has a problem and asks me to submit to M$. Weird, so I exit out, and see Internet Sharing is still saying 'waiting for connection'.

    So, I thought this was the standard WM61 instant messenger, and I was correct. I went to task manager, killed instant messenger just to see what would happen (despite the error, im.exe did not actually exit). I then canceled the Internet Sharing attempt (since nothing was working), and set it back to connect, so it waits. Set the MBP to connect using the Bluetooth PAN and bingo all works!

    So basically, Instant Messenger in WM61 causes Internet Connection Sharing to bork when you try to connect using Bluetooth PAN (haven't tried USB, can't get it to work at all). I don't know if anyone has seen this issue, or a fix for it? It's relatively easy to exit IM, but just annoying, and IMHO it shouldn't be doing this.

    Couple more tidbits: I have latest OSX and running Missing Sync.
    Thanks!
  2. ninjaap

    ninjaap Moderator

    Joined:
    Mar 23, 2008
    Messages:
    6,932
    Likes Received:
    22
    When you initially start IM a link gets placed in the Start Up folder. So it's usually running in the background when you boot up phone. If it's in the start up folder, try deleting it.
  3. kuruption

    kuruption New Member

    Joined:
    Aug 29, 2008
    Messages:
    8
    Likes Received:
    0
    Thanks, but I use IM, so I really want it running. :foot:
  4. ninjaap

    ninjaap Moderator

    Joined:
    Mar 23, 2008
    Messages:
    6,932
    Likes Received:
    22
    Is your IM's global settings set to connect to 'The Internet' and not WAP?
  5. kuruption

    kuruption New Member

    Joined:
    Aug 29, 2008
    Messages:
    8
    Likes Received:
    0
    Yes, it is set to 'The Internet'. When I tried to change it to WAP, the phone told me there was no WAP network configured. Cingular WAP is predefined under the proxy settings, but IM doesn't work with the WAP or Secure WAP settings.

Share This Page