VZW Q9C GPS Confirmation

Discussion in 'Moto Q 9c' started by pgreenbe305, Jun 16, 2008.

  1. pgreenbe305

    pgreenbe305 New Member

    VZW Q9C GPS Confirmation

    Hi folks! Quick question- I know that many have discussed VZW's locking of the GPS functionality, aside from VZNav, but I know many of you were trying to figure out a "work around." Has anyone figured that out yet, or has anyone heard? I searched, but the latest I could see was the discussion of it, and no answer on whether or not someone has cracked how to get access to the GPS chip for Windows Live, Google Maps, etc.

    Thanks!
  2. n99hockey

    n99hockey Moderator Staff Member

    dont think anyone got it yet
    although someone did post a sprint Q9c gps registry for someone to mess with
  3. tbhausen

    tbhausen New Member

    Jeez... gotta love VZW.

    Todd/Indy
  4. thebixcuit

    thebixcuit New Member

    I've requested many times that someone from Sprint get me some necessary files and even provided the tools to get them, but no one wants to contribute.
  5. BadBroncoBlues

    BadBroncoBlues New Member


    I think what you are referring to is this. It unlocks your GPS and turns it into aGPS, which means assisted gps. In other words it opens a port so that you can use Windows Live Search and Google Maps on your phone, and it allows for the cell phone towers to help/assist the gps so that it is more accurate and respondes quicker.

    • Dial ##073887*
    • Hit Send/Green Key
    • Enter your MSL
    • Hit H (GPS Settings)
    • Enter 68.28.31.49 for the IP address
    • Enter 5017 for the port number
    • Done/Exit
  6. Tojo1968

    Tojo1968 New Member

    When I hit send it asks for spc check, enter security code. What is that?
  7. BadBroncoBlues

    BadBroncoBlues New Member

    the security code that it asks for after you hit send is your MSL code. The MSL code is the one sprint used in programming your phone. If you do not have the MSL I would suggest calling sprint and informing them that:
    "I was trying to change my username on the phone and its asking for a msl code, can you help me with this?" or something to that effect.

    some sprint reps give it out freely, others well they are a pain and say they are not allowed to. for my wife's and my phone they gave it to me instantly, for my parents i had to call two times.
  8. pgreenbe305

    pgreenbe305 New Member

    Even for VZW...


    Thanks for the advice, but would this work for VZW, and if it does- is the IP and Port # going to be the same?
  9. pgreenbe305

    pgreenbe305 New Member

    VZW Code

    The SPC Code for a VZW phone is 000000. I found that on another forum, but I changed the settings as mentioned, and Google Maps is "Seeking GPS satellites (0)"- it has been for a while now. Maybe there is a different IP and Port for VZW? C'mon folks...
  10. CarNutInAZ

    CarNutInAZ New Member

    What do you need man? My Sprint Q9c has working GPS. I use google maps and windows live search/maps all the time. I just hit "Current GPS location" and it zooms right into my location. It even shows the buildings around me.

    Just give me some instructions and I will rip any registry entries or files that you need.

    - Jason

    P.S. I am confused. Are people saying that Verizon somehow locked the GPS so that people can't run apps like google maps and windows live using GPS? Why would they do that? Are you sure you guys just don't need to upgrade your data packages with verizon?
  11. MarkG121087

    MarkG121087 New Member

  12. VegasJ

    VegasJ New Member


    I can see it. My new Q9c ... I just got it and installed Google maps. When I go to options, use GPS, it sits with "seeking GPS satellites" for EVER! Verizon would want to block this out because if you have Google maps and GPS working you wouldn't need to spend $9.99/month on their own program, VZNavigator.
  13. VegasJ

    VegasJ New Member


    I get to "Hit H (GPS Settings) when I select 'ok' to go into that menu.... I get an "Alert" page that tells me "Modifying GPS settings disabled"

    Verizon pisses me off sometimes....
  14. bluesneaky

    bluesneaky New Member

    Yes so far it seems true, Verizon has locked th GPS out. I have tried the following Reg changes but still no luck.... If someone is able to use a Verizon 9c with something other than VZ Navigator please leave word of it. I have searched and searched but so far no luck. I am running short of days on my 30 day trial, if I cant get it I dont see whay I should keep the 9c over my original Q.

    Reg edits I have tried and things I have found (not listed it the Modoco com 4 activator but it didnt help either - GPS Test software has been a big help in telling if anything does work BTW):

    Originally Posted by MisterTedster
    So I discovered a different way of getting Garmin Mobile xt to work, and not only that, but to also avoid the battery drainage issues associated with using the COM4 activator. I take no credit for this as someone else discovered it, but I figured out that it was possible to use with garmin mobile xt. Not only that, but you can also set googlemaps and WLS to use the COM1 port and it works quite well, or you can use intermediate driver if you'd like. So make these changes to the registry and of course you need something to activate the GPS such as googlemaps or GPSTest.

    [HKLM\System\CurrentControlSet\
    GPS Intermediate Driver\Multiplexer\]
    String name="DriverInterface"
    String value="COM1:"

    [HKLM\System\CurrentControlSet\
    GPS Intermediate Driver\Multiplexer\ActiveDevice\]
    String name="DriverInterface"
    String value="COM1:"
    DWord name="Index"
    DWord value="1"
    String name="Prefix"
    String value="COM"
    (if you change the COM port #, I think you have to change the index to match: ie, com3 and index 3)

    [HKLM\System\CurrentControlSet\
    GPS Intermediate Driver\Drivers\GenericGPSDriver\]
    String name="CommPort"
    String value="GDD0:"
    (I believe this is the internal
    GPS port; I think this is the default setting...just making sure that it still is. you can check to make sure the internal GPS/intermediate GPS driver are working by using WLS or GMM and selecting intermediate driver and seeing if you can get a fix)

    Use GMM or
    WLS and try COM1 in the settings to see if you can still get GPS signal and location...

    These programs I was able to get to see
    GPS on COM1:
    Garmin Mobile xt
    Google Mobile Maps (2.0.0.11)
    Windows Live Search (2.5.2859.37360)
    gpsVP (0.3.7)
    trackr! (0.9.10)
    Sprint Navigation (1.0.13)(prolly uses intermediate
    GPS driver; worked before these edits and there are no settings in the program for GPS port...)

    These programs I was NOT able to get to see
    GPS on COM1:
    Efficasoft
    GPS Utilities (v2.0)
    Nav4All (8.0.62)
    Reperion (SF1.50)
    Virtual Earth
    Mobile (1.71)







    Under [HKLM\System\CurrentControlSet\GPS Intermediate Driver\]
    Is do any of you have a DWord named "IsEnabled" and, if so, what value is it set for? My Verizon Q9c has this value and it is set for "0". When I try to change it using Mobile Registry Editor, it says "access is denied". (note this was changed in my reg. to 1 and it still made no diference)


    These are the basic steps that you can try to get it working...

    1. Unlock the Q9C phone to install all applications.

    2. Then install Garmin
    GPS 10 Software: http://www8.garmin.com/support/downl...ls.jsp?id=3413

    4. Then install Garmin
    GPS 20 Sottware: http://www8.garmin.com/support/downl...ls.jsp?id=3389

    5. Get the Device ID within the About screen in Garmin.

    6. Installed the Maps from my official Garmin
    DVD.

    7. Transfer a few states over from my PC to my storage card.

    8. Using the Keygen 1.3, I create the two needed files, SW.UNL and GMAPSUPP.UNL and place it in the folder \Storage Card\Garmin, and also delete the Base Map.

    9. Now that everything is installed, run Google Maps and choose "Use
    GPS" to initialize the GPS.

    10. Going into Garmin settings and make sure you choose "Intermediate Driver" as your
    GPS. Then go to View Maps, and hopefully it'll say "Searching for Satellites." If it says "Searching for GPS Device", then you're not initializing the GPS correctly.

    But like I said, I'll have to investigate some more to find out exactly how to get it working. I'll re-install everything fresh and see if I can't get it working again. Might be a few days before I have a chance to do that though.



  15. VegasJ

    VegasJ New Member

    well, to triple check I went into settings, phone info, and scrolled down to 'Location(GPS): mine says 911 only.

    fricken bastards. why would I want to pay $10/month for something I can get for free? Verizon might get this Q9c back and dropped.


    well I feel like a douch. in network settings it WAS set to 911 only, so I changed it to location on.... but no workie.
  16. VegasJ

    VegasJ New Member

    I found this gem...

    http://msdn.microsoft.com/en-us/library/bb202034.aspx

    "The HKEY_LOCAL_MACHINE\ControlPanel\GPS Settings key contains an entry that identifies the name of the GPS interface software. The following table shows the registry entries. "

    when I goto that location in reg editor.... there IS no GPS folder. or software if I'm guessing right.

    also... "HKEY_LOCAL_MACHINE\System\CurrentControlSet\GPS Intermediate Driver"

    says (default) and has no value set

    does this mean Verizon advertizes a GPS enabled phone & sends out a GPS phone without the software? I wonder if the driver and software for the GPS is kindly coded in their VZNavigator software.

    can anyone take off from here? Is there a driver and/or software available? ...or am I asking the impossible?

    I have 29 days before I tell Verizon to stick it, but I really don't want to.
  17. BadBroncoBlues

    BadBroncoBlues New Member

    You may be very right about Verizon. Why not just go to Sprint? The Q9c is only $150 and if you get a SERO plan you will be spending a fraction of the cost that you did at verizon.
  18. BadBroncoBlues

    BadBroncoBlues New Member

    Ah I'm Sorry, I didnt catch that you were Verizon when you said VZNavigator, yeah from all that I have seen you are kinda screwed. like i mentioned already go SERO. 500 mins = $30 or 1250 mins = $49. both have unlimited nights at 7, unlimited data, text, picture......
  19. VegasJ

    VegasJ New Member


    I'vve been with Sprint before and their service actually sucks in most areas of Vegas. My last job had those push to talk radio/phones and throughout our office you'd constantly hear *beeeeeeep* (the sound they made when no service was available).

    ah well, 8gig iPhone comes out in July... :)

    hopefully I don't get banned from here for saying that!
  20. bluesneaky

    bluesneaky New Member

    Yea as someone else said here, its all about coverage. I travel a LOT and to remote off the wall places including Mexico. Verizon I thnk has better coverage all in all for someone like me. I would like to do the sprint thing and know they have some great deals but it doesnt do me much good to have a inexpensive plan if the phone wont work... Wish it did, Id say bye bye verizon in a heart beat for this little SNAFU.

    Hey by the way all, Verizon did lower the unlimited data plan from 44.99 to 29.99. They are not saying much about it and sure didnt lower my rate till I called them about it, but they did switch me over to the lower "unlimited data" plan tonight at 29.99/mo. If you are on the 45 dollar plan call them and ask to be switched over, thye dont seem to be doing it unless you ask. Here is a link to the press release about the lower data plan (I know off subject but hey its $ in our pocket, cut me some slack)

    http://news.vzw.com/news/2008/04/pr2008-04-14b.html

    Bye!

Share This Page