Video capture issue - file format is invalid

Discussion in 'Moto Q 9m' started by braj, Oct 11, 2008.

  1. braj

    braj New Member

    Joined:
    Aug 10, 2008
    Messages:
    242
    Likes Received:
    0
    Video capture issue - file format is invalid

    Hi all,

    I have an issue where my Q9h is displaying 'Alert: the file format is invalid.' when trying to play back videos taken on the phone. I have Kinoma Play and CorePlayer installed, in case that matters. I can take photos just fine.

    Thanks in advance for your help,

    braj
  2. mike250rs

    mike250rs New Member

    Joined:
    Nov 24, 2007
    Messages:
    14,284
    Likes Received:
    0
    do you have the file format set in file associations in core player
  3. BoostedKnight

    BoostedKnight New Member

    Joined:
    Aug 8, 2008
    Messages:
    334
    Likes Received:
    0
    There's another thread on here where I had posted about saying the same thing. I've tried taking videos of the phone and just playing them back with Windows Media Player and it's not playing in there either.
  4. mispentyouth

    mispentyouth New Member

    Joined:
    Oct 29, 2008
    Messages:
    62
    Likes Received:
    0
    Has anyone ever figured out this problem? I am also having this issue. Video files made by the phone will not play on the phone. I have searched the forums and seen a few posts about it but have not found a thread that has a solution.

    Kevin
  5. BoostedKnight

    BoostedKnight New Member

    Joined:
    Aug 8, 2008
    Messages:
    334
    Likes Received:
    0
    I never found a good solution or the root problem. I had to do a master clear of everything for another issue, but this issue was resolved as well when I started using the phone again.
  6. mispentyouth

    mispentyouth New Member

    Joined:
    Oct 29, 2008
    Messages:
    62
    Likes Received:
    0
    Just curious, does a Master Clear delete everything such as texts, contacts?
  7. manbat

    manbat Active Member

    Joined:
    Apr 17, 2008
    Messages:
    3,131
    Likes Received:
    3
    Just like a new phone......empty

    Makes it like a new phone.....nothing but stock....no contacts.....nothing.
  8. mispentyouth

    mispentyouth New Member

    Joined:
    Oct 29, 2008
    Messages:
    62
    Likes Received:
    0
  9. FourTwenSesh

    FourTwenSesh Active Member

    Joined:
    Mar 25, 2007
    Messages:
    2,844
    Likes Received:
    0
    You need the AAC vorbis codec for Core player if you want to view the Q's videos. It runs just like any other cab file on the Q.
  10. mispentyouth

    mispentyouth New Member

    Joined:
    Oct 29, 2008
    Messages:
    62
    Likes Received:
    0
    Any idea where I might find this codec? And why doesn't the phone have it already by default if it needs it to play its own video files??
  11. manbat

    manbat Active Member

    Joined:
    Apr 17, 2008
    Messages:
    3,131
    Likes Received:
    3
    I have never seen a Q that couldn't play it's on videos. The stock media player should play them fine.
  12. mispentyouth

    mispentyouth New Member

    Joined:
    Oct 29, 2008
    Messages:
    62
    Likes Received:
    0
    Hmm. I just took the .3gp files off the phone and onto my pc. I have Quicktime installed but if I try to open the .3gp files Quicktime gives me an error "Error -2048: Couldn't open the file because it is not a file that QuickTime understands." Is it possible the phone is making corrupt .3gp files and that's why it and my pc won't play them?
  13. mispentyouth

    mispentyouth New Member

    Joined:
    Oct 29, 2008
    Messages:
    62
    Likes Received:
    0
    Welp...after a simple powering off and back on of the phone, then recording another video it plays fine. But the ones recorded previously still say invalid format. Obviously that particular day my phone was recording incorrectly.
  14. manbat

    manbat Active Member

    Joined:
    Apr 17, 2008
    Messages:
    3,131
    Likes Received:
    3
    Are the videos saves to the sd card? I have had whole folders corrupt on an SD card before. I don't know why it happens. Old images would corrupt and new ones would be fine.
  15. BoostedKnight

    BoostedKnight New Member

    Joined:
    Aug 8, 2008
    Messages:
    334
    Likes Received:
    0
    That was basically the same exact issue I had, only power cycling didn't help it at all. Nothing did for months. Now that it works, the other files that are supposed to be the exact same format still won't play on my phone or computer. It's very odd indeed. Glad it's working for now.
  16. ParaCAD

    ParaCAD New Member

    Joined:
    Sep 19, 2008
    Messages:
    5,685
    Likes Received:
    0

    I've seen the error on my phone also. And my default is WMP. Yesterday i go looking thru my photos and videos ive taken. I play one video, i get that error, thinking wth. Then i scroll down to the next video, try to play that one and it plays just fine.

    Seems random how some will play some won't. none are more than 1-2min long. Its odd
  17. Q-Area51

    Q-Area51 Guest

    I have some vids from more than a year ago (maybe 2) and they all play fine in several apps that I use. Some are from a Q, some Q9m, some Q9c, and a bunch from various and sundry friend's phones. None are on the original SD cards and all of them have been moved and transferred from card to card to PC and back and in the end, I've never had a problem. I've followed this thread with interest and even asked a few friends who all reported no probs either. Obviously this is a considerable problem for some but it's very puzzeling. Just dunno. :) -Q
    (2 U from my Q9Nap)
  18. mispentyouth

    mispentyouth New Member

    Joined:
    Oct 29, 2008
    Messages:
    62
    Likes Received:
    0
    Yes they are saved on the storage card.
  19. Q-Area51

    Q-Area51 Guest

    Let me add . . . I've NEVER used any "cheap" cards either. Always top rated "brand name" ones. I don't mean to say that y'all do, just something to take into consideration. :) -Q
  20. BoostedKnight

    BoostedKnight New Member

    Joined:
    Aug 8, 2008
    Messages:
    334
    Likes Received:
    0
    Using a SanDisk 4gb micro sd.

Share This Page