Trouble with plantronics 520

Discussion in 'Bluetooth' started by droogie2799, Oct 3, 2008.

  1. droogie2799

    droogie2799 New Member

    Trouble with plantronics 520

    Just picked up a Moto Q9c and I am trying to pair my headset. Since i haven't paired my headset in a while I had to search for the pairing method. When you turn on the 520, and the headset isn't synced with anything, it will go into pairing mode. So, I turn on my headset, search for headsets from within bluetooth manager and the headset never shows up. I see my laptop as well as a few other devices, but never the headset.

    I did have the headset paired with my vx6800 for a while so I am fairly certain the headset is fine. Any ideas?
  2. rudeboy

    rudeboy New Member

    you have to press and hold the button on the 520 till the light start blinking red-blue-red-etc.. that means it's in pairing mode..

    potQ9c
  3. n99hockey

    n99hockey Moderator Staff Member

    you have to hold down the button until it blinks blue and red then its ready to pair
  4. droogie2799

    droogie2799 New Member

    That was it, like I said, I forgot how I originally paired my headset. Not sure why the manual said to just turn the headset on to get the device in pairing mode. Maybe I read wrong. Thanks again.

    Now I just need to figure out my g-sat BT sat receiver to work with google maps
  5. TreeFrog

    TreeFrog Active Member

    read the instructions this time!! =)
  6. rudeboy

    rudeboy New Member

    glad to help....

    for the BT "issue", follows TreeFrog's advice :}

Share This Page