Q9c keypad doesn't light up

Discussion in 'Moto Q 9c' started by Q9cDamon, Jan 24, 2010.

  1. Q9cDamon

    Q9cDamon New Member

    Joined:
    Jan 24, 2010
    Messages:
    6
    Likes Received:
    0
    Q9c keypad doesn't light up

    Hi, all. I'm new to the Q9c and this forum, having just bought my first Q9c. It's refurbished (looks brand new!) and updated to WM 6.1 Standard for Verizon--but the keypad doesn't ever light up! I have enabled and disabled the Smart Backlight with no success. I have also played with the registry settings for \HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Power\State using CERegEditor, but I'm not sure what they should be, and nothing I did solved the problem. Of course, this could be a bad hardware issue, but this is is the second phone I have received from the same seller, so I'm thinking it just might be a registry or ROM issue. Here are my questions:

    1) What are the correct registry settings necessary for the keypad light(s) to turn on and off properly on a Q9c that has been updated to WM 6.1 Standard for Verizon?

    2) What do the registry value names bkl1: and bkl2: in \HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Power\State refer to? What do the DWORD values 0, 1, 2, 3 and 4 for bkl1: and bkl2: signify?

    3) My phone indicates that it is running CE OS 5.2.19704 (Build 19704.1.1.50). Is this the most current version of WM 6.1 Standard? Is it the "official" version from Motorola?

    4) Can I flash my ROM back to WM 6.0? If so, does it make sense to try this to see if that fixes the problem? If so, where can I download the code and instructions to do this?

    5) Can I reflash my ROM using the "official" version of WM 6.1? If so, is there any special procedure I need to follow given that I already have WM 6.1 installed?

    If you think there is something else I should try, please let me know. I have spent many hours over the past week trying to solve this on my own, so I'm hoping you can help me resolve this. Thanks in advance.

    Damon
  2. mike250rs

    mike250rs New Member

    Joined:
    Nov 24, 2007
    Messages:
    14,284
    Likes Received:
    0
    you said that you updated to 6.1... did the lights work before the upgrade?

    My keypad does that once in a while after using the camera in low light. Most time turning off & on the smart backlight works.

    You can reflash it using RSDlite. Look around for the correct monster flash ROM file. Make a backup of your data first.
  3. Q9cDamon

    Q9cDamon New Member

    Joined:
    Jan 24, 2010
    Messages:
    6
    Likes Received:
    0
    Thanks, mike250rs. The phone had been upgraded to WM 6.1 before I purchased it, perhaps as part of the refurb process, so I don't know if the keypad lights were working before the upgrade. Do you think I should reflash the phone to WM 6.0 to find out? Is that even possible?
  4. mike250rs

    mike250rs New Member

    Joined:
    Nov 24, 2007
    Messages:
    14,284
    Likes Received:
    0
    it can be downgraded.. hardest part will be finding the correct ROM.

    Could also be a hardware issue. A bad connection/keyboard. If your feeling frisky you can pop it open and give it a quick check. Distructions on taking one apart are here..somplace. Replacement keypads are cheap. www.cnn.cn last I checked they were on backorder.
  5. Q9cDamon

    Q9cDamon New Member

    Joined:
    Jan 24, 2010
    Messages:
    6
    Likes Received:
    0
    Thanks again, mike250rs. The seller has agreed to take the phone back, so I'm going to return it. I have ordered a new Q9c from another seller. Hopefully this one will work.

    Damon

Share This Page