Push or sync gmail on focus

Discussion in 'Samsung Focus' started by LifeAquatic, Jan 7, 2011.

  1. LifeAquatic

    LifeAquatic New Member

    Joined:
    Jan 3, 2011
    Messages:
    8
    Likes Received:
    1
    Hi, just got my new Focus earlier this week and couldn't be happier. A question regarding gmail - I set up the sync as "as items arrive" but there is a noticeable delay in pushing the new mail, sometimes when I am on wi-fi and open my gmail, the new mail doesn't even show up unless I click on the sync button. What gives? It used to update new mails rather quickly when I first got the phone but now it is more random. I am concerned about missing important mails... Any help would be appreciated!
  2. termleech

    termleech Member

    Joined:
    Jun 20, 2010
    Messages:
    166
    Likes Received:
    4
    Have you tried rebooting the phone? Could just be your push service is hung up. I haven't had the issue yet, all my gmails pretty much show up instanteously but a reboot usually fixes things like that.
  3. LifeAquatic

    LifeAquatic New Member

    Joined:
    Jan 3, 2011
    Messages:
    8
    Likes Received:
    1
    On WiFi only, the push is really sporadic - sometimes it works sometimes it doesn't. I can't isolate the reason, I.e. Is it having too many sync mail accounts, etc. It seems to work ok as long as the 3g data is also on
    but I read that having both on there could be data leeching from the 3g even while the WiFi is active.
  4. ninjaap

    ninjaap Moderator

    Joined:
    Mar 23, 2008
    Messages:
    6,932
    Likes Received:
    22
    When your phone connects automatically to wifi, some apps may take a few before it establishes a proper connection. Therefore, it may take some time to actually sync your emails. I see the connection issue with IE and Marketplace as well. Usually restarting the app will force the connection.
  5. achmeingott

    achmeingott New Member

    Joined:
    Jan 15, 2011
    Messages:
    4
    Likes Received:
    0
    Gmail actually can use Activesync which is similar to the Exchange server. The absolute best way to set up your gmail account and enable true push is to go to email & accounts>add an account and choose the "Outlook" option instead of "Google". type in the full name and password, click sign in. For username type your full email address, then under domain type "m.google.com" and continue. It'll tell you it can't find settings, click "advanced". For server type "m.google.com". This will set it up to automatically sync email, contacts and calendars. Your emails should also arrive much more quickly.
  6. ninjaap

    ninjaap Moderator

    Joined:
    Mar 23, 2008
    Messages:
    6,932
    Likes Received:
    22
    Works like a charm, achmeingott! Now to see if it's more reliable.
  7. LifeAquatic

    LifeAquatic New Member

    Joined:
    Jan 3, 2011
    Messages:
    8
    Likes Received:
    1
    what ninjaap said about the wifi having to reconnect makes sense - I used to turn the 3g data connection off, but I think the phone is smart enough to switch to wifi when it is available. When both wifi + 3g on, new emails get pushed instantaneously, and without adding significantly to the data plan throughout the day (I checked).
  8. ninjaap

    ninjaap Moderator

    Joined:
    Mar 23, 2008
    Messages:
    6,932
    Likes Received:
    22
    Only been using Gmail with Outlook for a day, and already got a few late emails just as I did when I set up Gmail the normal way. This leads me to think it's a connection issue more than it is a push issue.
  9. cheshirecat

    cheshirecat New Member

    Joined:
    Feb 8, 2011
    Messages:
    23
    Likes Received:
    2
    My gmail link is very fast. I use sync [and it shows it going through Windows Live]. I have my gmail going to my desktop, my iPad, and my Focus. The timing is different for all but the Focus and desktop is the fastest usually.

Share This Page