Problems with apps

Discussion in 'Moto Q 11' started by gaucho.andre, Mar 15, 2009.

  1. gaucho.andre

    gaucho.andre New Member

    Problems with apps

    Hi everyone. I've just bought my moto q11 and i'm having problems with installing applications on it. All apps i install show the following error message when i try to execute it:

    "Error

    An unexpected error has occurred in "app name".
    Select Quit and then restart this program, or select Details for more information."

    Selecting detaisl i've the following infos:

    "GAlarm.exe
    Not Supported Exception

    at Microsoft.AGL.Common.MISC.HandleAr()
    at Microsoft.WindowsCE.Forms.InputPanel..ctor()
    at GAlarm.frmStart.InitializeComponent()
    at GAlarm.frmStart..ctor()
    at GAlarm.Program.Main()"

    This problem has happened in more than one app. If you don't know how to solve this problem could you please tell me one app you've installed in your mot q11 so that i can install on mine and check if the problem happen again?

    Thanks
  2. dafoxs

    dafoxs New Member

    Not may Q11 people here, hope someone can help. Were do you live?
  3. mike250rs

    mike250rs New Member

    Just a shot in the dark....

    you are installing the smartphone versions of the apps and not the ppc ones?
  4. gaucho.andre

    gaucho.andre New Member

    I really don't know the diference. I've just searched on the web for "applications for windows mobile 6.1" and downloaded the ".cab" file. I've seen in the internet that to install the .cab i should transfer it to my mobile and install it from the mobile. i've done that, but whenever i try to run the application that error occurs. Is there a way to check if the application is not suitable for a mobile? All .cab archives are mobile instalators or some of them may be for ppc?
  5. dafoxs

    dafoxs New Member

    I don't know about the 11, you may need to call your provider. It should tell you if it wont work. Again, not many 11 users here.
  6. gaucho.andre

    gaucho.andre New Member

    Yeah, in last case i'm contacting the provider, but i wish i could find the solution on the web. The Q11's manual is so poor, that i think a contact with the provider won't be easy.
  7. Q-Area51

    Q-Area51 Guest

    gAlarm is a PC app. Are you sure you have the right one. .cab doesn't only apply to WM. :) -Q
  8. Q-Area51

    Q-Area51 Guest

    K . . . Here's the install info:

    G-Alarm Online Manual


    Installation instructions for G-Alarm

    How to install .cab files

    1. Download the .cab file to your computer. If you can download it directly to your PDA just jump to point 4.
    2. Copy the .cab file to your PDA via ActiveSync, Windows Mobile device center or Bluetooth.
      Although the downloaded file may look like an archive, don't extract it! Simply copy the file as you downloaded it to your PDA!
    3. Turn your computer off because you don't need it anymore ;-)
    4. On your PDA: Browse to where you downloaded/copied the file with the file explorer.
    5. Click on the file - an installation screen should now appear.
    6. Follow the steps (installation directly on your device/ROM is recommended for G-Alarm) and finish the installation.
    7. You can find the installed tool under Programs.
    8. Have fun with it!
    9. If G-Alarm tells you that it needs a newer version of the .NET Compact Framework you can find it here.



    Do you have .net 3.5 installed? :) -Q
  9. dafoxs

    dafoxs New Member

    I'm thinking if it doesn't install then, It isn't meant to be.
  10. brandon.roeder

    brandon.roeder New Member

    you need to install .net 3.5.

    I ran into this problem last night. install it and you should be fine
  11. gaucho.andre

    gaucho.andre New Member

    Thanks guys. I've realized i have .net compact framework 2.0.7045.0.

    But this download link gives you the .net 3.5 in a binary file and not in a .cab file. Is there any problem? Or i should just transfer it to my mobile and run it as it was a normal instaler?
  12. Q-Area51

    Q-Area51 Guest

    You must install 3.5 on your PC WHILE connected via Active Sync and it will be installed to both your PC AND your Q. :) -Q
  13. gaucho.andre

    gaucho.andre New Member

    I've sucessfully instaled .net 3.5 but the error is still there. I've checked the cgautil.exe inside the windows directory on my mobile and it tells me i have the version 3.5 installed. However the same error is occuring. The worst problem is that it only tells me:

    "GAlarm.exe
    NotSupportedException"

    I have no clue of how to fix it. Do you have any more tips? Maybe guesses?
  14. Q-Area51

    Q-Area51 Guest

    YUP!!! You are right! I just tried installing it to and it appears to install BUT upon starting it . . . the ERROR!! Dunno - BRANDON - whatchy got for us ???? :) -Q
  15. dafoxs

    dafoxs New Member

    good call, I didn't think of that
  16. Q-Area51

    Q-Area51 Guest

    THANKS fox . . . I had suggested it BEFORE but apparently you missed it. NO prob.

    It must be a Q11/Nap thing. :) -Q
  17. gaucho.andre

    gaucho.andre New Member

    Guys, could you suggest me one app you've installed on your moto q11? I just want to install something, just to check if there isn't any big problem with my mobile.
  18. PacoJr67

    PacoJr67 Active Member

    according to their website g-alarm is a PPC app (which Q-area51 already mentioned), meaning that a touch screen is required.
  19. mike250rs

    mike250rs New Member

    wow...my shot in the dark tech support ain't half bad
  20. PacoJr67

    PacoJr67 Active Member

    nope, not half bad at all
    when it mentioned integration with S2U2 I knew...

Share This Page