problem with sms on GSM network

Discussion in 'Moto Q 9n' started by Qcumber, Apr 30, 2009.

  1. Qcumber

    Qcumber New Member

    Joined:
    May 23, 2008
    Messages:
    18
    Likes Received:
    0
    problem with sms on GSM network

    Guys, I'm using the Nap on GSM network (Russia) and problem I have is that I can receive sms no problem but whenever I send one the recpient only gets first letter of the message and numerous "@" after it. I think the problem might be that network identifies my phone number incorrectly. If I go to Settings -> Phone -> Call Options then under "Phone number:" I see 0000009115 which surely is not the number I use. I wonder if anyone could spill any light? I love this phone and am frustrated over this problem.
    I have h/w version 3.2 and flashed 1.31 firmware. Tried 1.34 to see if it would fix problem but to no avail. Networks is set to "GSM only"; selecting "Global" doeesn't help.
  2. ninjaap

    ninjaap Moderator

    Joined:
    Mar 23, 2008
    Messages:
    6,932
    Likes Received:
    22
    Probably not the problem. I used my Nap in the Philippines with a local sim card and my phone number from the US still appeared under call options.
  3. dreys

    dreys New Member

    Joined:
    Jul 26, 2008
    Messages:
    4
    Likes Received:
    0
    I assume you type in Latin and not Cyrillic? Have you tried using other phone with the same GSM card?

    I had no problems using several US-made phone on both MTS and Bee-Line, all worked fine.
  4. Qcumber

    Qcumber New Member

    Joined:
    May 23, 2008
    Messages:
    18
    Likes Received:
    0
    Latin, yes. Same SIM card works fine with all other phones including Q8. I've also tried another SIM card with Napoleon (different provider) and sms I send are still nor readable. So the problem is within the phone...
  5. Qcumber

    Qcumber New Member

    Joined:
    May 23, 2008
    Messages:
    18
    Likes Received:
    0
    Problem fixed upon disabling Unicode in Messges -> Settings. Now people can read my sms. It's strange though that enabled Unicode had such a disastrous effect.
  6. ninjaap

    ninjaap Moderator

    Joined:
    Mar 23, 2008
    Messages:
    6,932
    Likes Received:
    22
    Hey good job. Thanks for updating us.

Share This Page