Here's how to get Google Maps My Location working!

Discussion in 'Samsung Saga' started by larsdennert, Apr 13, 2009.

  1. larsdennert

    larsdennert Active Member

    Ok sorry we have technologies in one thread.

    Googlemaps and virtual gps.

    Let's focus on the one that works better, virtual gps.
    You need two things to get working. The cab file you can get from skyhookwireless.com or my site. Install that.
    Secondly you have to program it with a username and realm. It will NOT work without those. Register for that at skyhook's site. Note the com port that wps uses after you install and activate the app. Set all your gps apps to that com port. You can set google to use that one two and it works many times better than google's native location services.

    If you have an external gps you want to use in conjuntion. Configure that in the wps and wifi plus gps will integrate together.
  2. EQBob

    EQBob New Member

    ok...several questions, most of which may be dense, so be gentle...<G>

    1) and your site would be where? <G> (there's no sig, so ....)
    2) what's wps?
    3) what's a realm? (other than harkening back to the days of might and magic)
    4) This skyhook thing....will it affect the real GPS when Verizon unlocks it?
  3. larsdennert

    larsdennert Active Member

    1 yea you're probably posting from phone. www.larsdennert.com
    2 wifi pos sys
    3 you'll see when you get that far
    4 nope it'll only help because it locks in seconds. from what I've read the omnia takes a while
  4. pat_the_cat

    pat_the_cat New Member

    I also can't get this to work on my Saga. I followed the PDF instructions from Skyhook. I changed ports on both Live Search and Google Maps. Still nothing. Does this work better if you are near more hotspots? I have WiFi at my house and live in a pretty rural area-I am the only WiFi spot that my phone or laptop picks up. Does this have anything to do with it?
  5. larsdennert

    larsdennert Active Member

    Yea likely. It works better in cities. submit your access point to their db from their website.
  6. EQBob

    EQBob New Member

    I'm not sure how well this will work around here either. Certainly in some places there are some hotspots, but I'm not really sure how many. Certainly tho', traveling down the main arterials, there aren't side by side businesses the whole way that have hot spots, so just really not sure.

    Is there some dB some where of what public hot spots are recognized? I've never gone looking for any such public hot spot unless I'm in a hotel and trying not to pay the 9.99 a night internet fee for reading email for 30 minutes.<G>
  7. jmorisey

    jmorisey New Member

    Go figure, I have been to busy to jump on this as soon as you guys started talking about it... now that I have a little time, I downloaded it and installed it, but I can't get registered... keeps telling me internal error.

    Is it worth my frustration? Should I keep trying?
  8. dragonfly

    dragonfly New Member

    when does it say that you need to register it? which part of the install?
  9. jmorisey

    jmorisey New Member

    Their webpage... at the Developers SDK Download... I put in my registration information and use Larsdennert's realm, and it tells me there is a database error or something...
  10. dragonfly

    dragonfly New Member

    I recommend creating your own realm and user name info thats what i did and it works perfectly fine :)
  11. fitfestus

    fitfestus New Member

    hot spots

    hey dragonfly,

    how do you register your home hot-spot?
    I looked all over their website for that and cant find it...

    I got the cab installed, but cant get google maps to find anything.
    I also am in a rural area, so maybe it wont work till i register my hot spot...

    please advise....
  12. dragonfly

    dragonfly New Member

    I didnt register my home hot-spot. Some areas i have noticed it cant find you. most of the places i drive it can for the most part. Down the shore this past weekend it couldnt find me at the sonic near my shore house but after i drove down the rd it finds me.

    Make sure that the ports for google maps and for the wps settings are the same, mine for instance are set for port (com8) and make sure that in the WPS settings the GPS settings are set to auto for the com port. and make sure that in the authentication tab you have the user name and realm that you registered with.
    And last thing you would need to check in the WPS settings program is the service make sure its set to "active"

    The one thing you should notice if you have everything in properly and the service is active in google maps when you click on "use gps" it should say Something about gps in the upper right hand corner with a very long number next to it in paranthesis (sry if i spelt that wrong).
  13. fitfestus

    fitfestus New Member

    I have my google maps GPS set on port 8.
    Do you have a baud rate set or did you leave that blank?

    does it matter if you are actually connected to a wireless device, or that wi-fi is turned on?

    I also DON'T get any numbers in the Upper Right hand corner in Google Maps. I get just that it is "Initializing GPS"
  14. dragonfly

    dragonfly New Member

    My baudrate is set to 4800 my phone set it to that automatically when i did the auto setting for the COM port. I believe that the program turns on your wifi if its off either way. I would try to turn on the wifi and than try to run it and see if you get any signal its starting to work. Make sure the gps setting on the wps thing is COM8 also. let me know if this works for you, did you get that very long number on your google maps when you select to use gps?
    o and you do not have to be connected to any wifi spot.
  15. fitfestus

    fitfestus New Member

    I checked all of my Google Maps Settings.
    - The COM Port is set to COM 8 - as is the Port settings in the WPS Setting Program
    - I tried all of the Baud settings that Google Offered
    - I just got "initializing GPS" for every one I used. I was not able to get any numbers when it was searching.
    ++ WPS Setting Program ++
    - Auth Tab - I verified my Authentication Settings on the WPS Setting program from the Username and Realm that I registered with....so those are good.
    - Port Tab - WPS Port: COM8
    - GPS Settings in the WPS Setting Program is set to Auto, even though I dont think that has anything to do w/ outgoing. Looks like this GPS setting has to do w/ an incoming GPS signal.
    - Service tab - The Service is Active

    - Wi-Fi is also turned on
    - I also tried a soft reboot.
  16. blackmeto

    blackmeto Active Member

    had you tried anyother gps solutions on your phone?
    I had tried one before that had no way of uninstalling unless i did a hard reset
    Needless to say it didnt work until i did a hard reset and reinstalled
  17. larsdennert

    larsdennert Active Member

    http://www.skyhookwireless.com/howitworks/submit_ap.php You need the MAC address of the WIFI adapter in your router. Your router may have MAC addresses for the WAN portion too. Don't use those.

    Ideally you don't want your phone to be connected to a wifi access point or it will stop scanning for AP's. This was my experience to GM's built in location service.

    In the WPS program lookup the "WPS port:" and set that in your other apps to match. This setting is under the "Port" tab. I recommend Com6 unless you are using it for something. com8 is suspected to be the hardware gps port.

    OPTIONALLY, in the WPS program you can go to the GPS tab and set the com port of an external gps unit to integrate with wifi location. If you are unsure what you are doing, IGNORE the gps tab.
  18. larsdennert

    larsdennert Active Member

    I have one more comment! Don't abuse this service. I fear that if too many people abuse it we will get shut down. It was, I believe, to allow software developers a way to test LBS apps. You've been warned.
  19. fitfestus

    fitfestus New Member

    i am hoping there are other options that doing a hard reset.
    any other options?
  20. dragonfly

    dragonfly New Member

    Well like blackmeto asked did you ever try any other alternative methods to doing the gps on your phone? I know thats caused alot of issues for people trying to use this gps fix. and the hard reset was the only thing that worked for them from what i believe, guess im lucky i got it working :)

Share This Page