Garmin Mobile XT and Q9c

Discussion in 'Moto Q 9c' started by mtbron, Feb 11, 2008.

  1. Skadoosh

    Skadoosh New Member

    Help!!

    Hi,

    I've got Garmin Mobile Xt fully installed on My Q9h, but am having a hell of a time getting any bars. I don't know what to do. I've tried all i can think of, read so much text on the subject my eyes hurt, and still nothin. I've hit a wall and am looking for your help, someones help. Any advice. Thanks.
  2. MisterTedster

    MisterTedster New Member

    You may have set the accuracy of the gps settings in your phone to too low a value. default is 256 and works just fine

    -from my q9c
  3. Skadoosh

    Skadoosh New Member

    You've lost me. When I first go into XT, I click "I agree", and then "skip" so it doesn't scan for bluetooth. I've then gone and disbaled bluetooth, and used COM4. I get zero bars, nothing. I've got no idea how to go into anythign and change settings. Does my phone need to be unlocked? have you got any steps in mind that I need to take? Thanks!
  4. MisterTedster

    MisterTedster New Member

    First of all, I would recommend you do the COM1 hack I posted on page 4 or so, then set garmin mobile to com1. Then go into you start menu and go to settings then phone settings and then gps settings and just set the accuracy to 256. I think thats where it is. If you're on wm6.1 then don,t worry about gps settings. I assume you have already applied the unlock app in the hack sticky before you can do any registry edits. Hope that helps!

    -from my Q9c
  5. Skadoosh

    Skadoosh New Member

    I really appreciate you helping me. Can you get me started by telling me how to get into where I install the com1 hack?
    I've got WM 6.0.. I also can't find where the GPS settings are. Sorry, I'm having a bit of time with this.
  6. fr4nk1yn

    fr4nk1yn New Member

    I just found something interesting in some unrelated web browsing.
    I'm SURE it was posted by a member and maybe we'll get some good instructions out of it. It was posted for a 9h though.

    I'm not sure why I'm even trying again to get this working with two other GPS programs on my phone now.
  7. Skadoosh

    Skadoosh New Member

    I have a 9h. What do you have for me? Thanks!!
  8. fr4nk1yn

    fr4nk1yn New Member

    Me? I have nothing :)
    Check you PMs though.

    Well I still didn't get a signal. I'll try the COM:1 hack, hope it works with Sprint Navigation, and try again.
  9. kamran5461

    kamran5461 New Member

    I have Q9c with WM 6.1 and garmin mobile xt 5.0010 .
    the built-in gps device shows up under gps intermediate driver. but when i run garmin mobile, it keeps searching for satellites. i managed to get a feeble signal once when i left it over night by the window. but since then no luck.
    i also tried google maps and the gps works great and the accuracy is within a meter. why is it that google maps can find the gps signal right away where as for garmin, its a almost impossible feat?

    anyone found a better map software like tomtom to work better with motorola Q?
  10. robotphood

    robotphood New Member

    The only way garmin works on my q9c is the Com1 hack and using gpstest (gmaps works also) to activate the gps so that garmin can access it. Combined with the agps hack, a satellite lock should be fairly quick (10-15 sec).

    As for other software, I personally find Garmin is the best . I don't think TomTom works very well on the Q even if you get it running. Sprint Navigation is slightly better, but only because it reads street names (I prefer stored maps from experience).
  11. fr4nk1yn

    fr4nk1yn New Member

    Live Search is the best thing going in my opinion.
    The COM1: hack doesn't always work. It didn't for me.
    I still find Sprint Nav horrible. Slow and bad searching sometimes very laggy.

    Live Found me a great restaurant in DC for a very specific item my father wanted and got me around where Sprint Nav was unusable.

    I'd like to try Garmin but I've given up on the internal GPS and if I were to buy an external I might as well buy a stand alone.
  12. robotphood

    robotphood New Member

    For me, voice guided navi is pretty important. The thing I like about Sprint Nav is that I'd rarely have to look at the phone with full voice cues. One problem I had with it was that if I was in a slow evdo area (or non evdo) it would take a bit to reroute or frequently reroute because of a dodgy connection. Also if I received calls while routing, it would have to completely reroute when I resumed and that sometimes took a while and put me off a bit off track. With Garmin, resuming would be quick because the maps were preloaded. Without street names though, I have to glance at the phone on occasion because for instance, it'd say "take ramp right" but there will be multiple ramps (Los Angeles!). I'd still use Sprint Navi though since it worked well most of the time. If only Sprint didn't mess up my billing and take off my data package that included it, giving me an option to pay more for something I already had.... Garmin it is for now, until I find the strength to argue at lengths again...
  13. MisterTedster

    MisterTedster New Member

    Both TomTom5 and TomTom6 didnt work for me. They also require another mouse simulator software to work with smartphones. Im keeping an eye out on amAze gps which is like sprint navi but free. They havent gotten it to run on the q9c correctly yet but theyre making good progress.

    -from my q9c
  14. k_semler

    k_semler New Member

    amAze gps also does not work on the Motorola Q9h.
  15. kamran5461

    kamran5461 New Member

    hmm. i guess i am not alone in this predicament. i would try com 1 hack but it is designated for a bluetooth port and my headset is paired with it. Besides, my problem isn't locating the internal gps device, garmin is able to do that, the problem is getting a satellite signal.
    i thought maybe the onboard gps on my phone is like that shitty integrated graphics card a pc comes with. but google maps uses the same device and makes full use of it. even though i have a stand alone gps in my car, i still wanna make garmin work on my phone or else it will keep bugging me. anyone of you feel that way about making things work? lol
  16. fr4nk1yn

    fr4nk1yn New Member

    I get into those moods.
    I have no idea how much time and bandwidth I put into getting Garmin working with no success.

    Just foe the record it will pick up the built in GPS but won't connect to the sattalites.
    It won't find the GPS with the COM1: hack at all.
  17. springc

    springc New Member

    Ok. I would like to share my experience with you guys. Hope it helps.
    I found that to get the Garmin to detect and use the internal GPS in your Q9c. You have to use version 4.10.xx. Those 4.20.xx and the newest 5.xx doesn't work. I did the COM1 hack, and I use GPSTEST to kick off the gps before I run garmin.
    For the 4.10.xx, I tried 2 versions:
    1. GarminMobileXTforPocketPCwithGPS10_41001wBeta
    it is oberviously old version. In gps selection, there is no intermediate driver, only com port. And I believe for this version, you don't need GPSTEST to kick off the gps. Only draw back is, it will attempt to power on the bluetooth first and search. But once you disable it, it will find COM1:COM1 as gps device and find satellite with it.
    2. GarminMobileXTforWindowsMobile_41040w.exe downloaded from garmin official website. it is an upgrade version, so you will need to install supporting files (voice) and basemap seperately. This version has 3 choice for GPS, bluetooth, intermediate driver, and serial port. You have to kick off the GPS with GPSTEST (or google map) first. I did have COM1 hack and I believe it is necessary. You need to select serial port com1 (or whatever port you hack). If it shows gps device as COM1:COM1, then it is successful. If it reverts to intermediate driver, then you won't able to find satellite. You have to check if you kick off the gps, and then try to select the COM1 again.

    I tried all those 4.20.xx (4.20.30w, 4.20.50w) and the recent 5.00.10w. They all fail on my Q9C. However, I installed on a PDA and work with the bluetooth GPS (it use some software to reroute the bluetooth signal to some com port), that works fine. I also installed on a Pharos GPS 525 PDA, which has a built-in GPS, and it works fine (both 4.20.50w and 5.00.10w) no need to use other software to kick off the gps.

    I hope these experience helps. And I would be glad if someone point out that they get their Q9c to work with 4.20.xx (I saw one post in this thread mentioned about installing 4.10.xx first and then install 4.20.xx on top of that, but I don't have any success). I would like to use the newest 5.00.10w too.



  18. robotphood

    robotphood New Member

    Have you tried the agps hack? My q9c can recognize the gps but I can't lock satellites without it.
  19. hetalakapadia

    hetalakapadia Member

    Springc,

    What happens when you disable data connection on your cell phone and run gpstest? Does it kick start gps for you?

    Thanks,
    Hetal
  20. springc

    springc New Member

    disable data connection? I don't think I did. I have unlimited data plan. Does gpstest need data connection? I don't know how to disable data connection.
    I have to wait until gpstest detects several satellite before my garmin can pick up the gps device in com1.

    Also, I did activate the aGPS hack when I get the phone.

Share This Page