Forced Security Policy

Discussion in 'Moto Q Hacks' started by Lucky13MN, Jan 23, 2008.

  1. zenkinz

    zenkinz New Member

    this function runs automatically whenever there's a change in the policy, it runs on the background, so there's no user intervention required.

    I wrote the program when I was using pocketpc phones. Never did I thought that I will be owning a smartphone, otherwise I would have tested for its compatibility.
  2. santana

    santana New Member

    well i wanted to bring this topic backup because maybe someone can help out with a separate problem in the same field. on a q9m the policies in that same folder vary somewhat. but i havent been able to find out what does what.. its clear that "000001023" will lock or unlock the device lock menu. but i am looking for the option that will respectively device lock the q9m after the amount of time set in that same security option menu.

    ie the regular Q if you device lock after 24 hours it will only prompt for the password after 24hours of not being used.. so if you unlock your keys it will not ask you for the password within that time. on the other hand the q9m will ask for the password regardless of the amount of time waited every single time you want to unlock the keys. very annoying.

    suggestions anyone please?
  3. zenkinz

    zenkinz New Member

    if you are asking if you can do key unlock w/o password on certain condition, I don't think that's possible, at least not that I know of. Once security policy is enforced (to have password to key lock your device), it doesn't matter if your device is locked after the timeout (e.g. 4 hrs after inactivity) or you have manually keylock the device yourself, you still have to use password to unlock it.
  4. zenkinz

    zenkinz New Member

    fwiw, I have successfully ported the hack utility to smartphone platform, which means Q9h can use this hack utility now :D Let me know if you want a copy.
  5. das_wookie

    das_wookie New Member

    Dude, you RULE! I'd been dealing with that IT installed crap after syncing with our corp exchange server for months before it finally lit me enough today to try to figure out some hack around that crap... this worked like a dream. Fix the reg entry, go into security... turn OFF the previous greyed out keylock, and BINGO! W0OT!!!1

    Thanks!!!
  6. TreeFrog

    TreeFrog Active Member

    oh yea...bummed me out for months as well!
  7. marjwilliams

    marjwilliams New Member

    Thanks to Tree Frog this bummed me out for exactly 3 hours! Most excellent.
  8. torquet

    torquet New Member

    I have tried this but my phone still locks after 20min or so. Damn IT
  9. jkabaseball

    jkabaseball New Member

    same here. I do all the hacks, and it reverts back. So i looks like some how my exchange server is set to enforce the policy everything it syncs
  10. TreeFrog

    TreeFrog Active Member

    there is a small app that automatically re-issues this hack when the security is forced again. I've been looking for awhile now and cant find it! I never needed it...if I find it I'll post back!
  11. santana

    santana New Member

    hemm maybe I didnt explain the issue correctly. the issue with the q9m compared to the first q is that it prompts for a device unlock pin everytime you want to unlock the keys. on the first gen Q there was a difference between keypadlock and device lock. you could lock ur keys within the time specified of inactivity without being prompted for a device unlock pin. if you left it idle past the time set you would then have to unlock the device with your pin. q9m will prompt you for the pin every time you attempt to unlock your keypad regardless of the time limit set to auto lock the device.

    I was hoping there was a registry setting I could change or modify to use the devicelock / keypad lock feature separately as it was with the first gen Q.

    anythoughts or suggestions would be appreciated.
  12. coldfyre22

    coldfyre22 New Member

    Zenyee's program works like a charm on my Q. The exchange server here seems liek every so often randomly attempts during a sync to enforce the registry policy to reenable the lock and the program that runs in the background stop sit everytime.

    THANKS ZEN!!
  13. stasis

    stasis New Member

    I dont get why I cant copy most files from the windows directory, mostly all exe and dll get access denied when I try to copy to desktop. I want to extract icons in order to use them on the sliding panels. I tried the enable rapi and using Security Config Manager to totally disable security but still nothing...
  14. twinklit

    twinklit New Member

    I am VERY interested in this program for WM6, you're awesome for writing this prog!!!!!! Please PM me where I could DL it from. Thanks!
  15. TreeFrog

    TreeFrog Active Member

    :smile: Here Go! :smile:
  16. twinklit

    twinklit New Member

    I'm trying to install Zen's STAY UNLOCK software and it's recommend to place it in the windows/startup folder of my windows mobile so that it will load after a soft reset.........but does anyone know how to access this directory? I have a Q9C on WM6 (some say it works with their WM6 so I'm going to give it a try too). Thank you!
  17. TreeFrog

    TreeFrog Active Member

    You may need to go into your file explorer settings and set it to be able to view system files/folders...etc.
  18. twinklit

    twinklit New Member

    yep that exposed the directories so that I could see them, fingers crossed hopefully there's no more updates :gasp:
  19. bheidemann

    bheidemann New Member

    Did you ever get a solution for this? I am in the same boat, I don't mind that I have to enter the password every 4 hours but every time I unlock the keys is just silly. My original black Q worked great but having to enter the password just to unlock the keys is stupid.
  20. TreeFrog

    TreeFrog Active Member

    I havn't seen or found a fix for that....just a lovely feature we got when we moved off the Q1!! I did a pretty hard knock down search too.....

Share This Page