activesync issue solved

Discussion in 'Moto Q 9c' started by jamie3529gq, Mar 24, 2010.

  1. jamie3529gq

    jamie3529gq New Member

    Joined:
    Mar 24, 2010
    Messages:
    2
    Likes Received:
    0
    activesync issue solved

    I have struggled with connecting to my company's exchange server, I had the 'waiting for network' error and 'invalid certificate' error. I ran Microsoft's Sslchainsaver program to obtain the certificates from our company server, and installed them on my phone. I was able to sync using USB and activesync 4.5 (on XP) with no issues, but no matter what I did the phone would not sync over the air.

    On an older Moto Q I was able to perform a registry change to tell the phone to ignore certificate mismatch, and it worked fine. But I recently changed to a q9c, and that registry hack doesn't work. :-(

    To get to our company outlook webaccess, two different (but very similar) URL's are used. One is, as an example webmail.ourcompanyauto.com, while the other is webmail.ourcompanyautomotive.com The certificates are similarly named. (both get to OWA while in the company network, but only one will get to OWA from outside). It turns out that the certificates I installed while at my desk were different than those needed to connect while outside the company network.

    So I ran the sslchainsaver program from home, to the outside webaccess url, and installed those certificates on my phone. And voila!!! It works.

    I will find out tomorrow if the phone still syncs with USB to my pc..... it should, since it now has both internal and external certificates.

    I have never seen a solution like this in the many forums and many many posts I visited trying to solve the problem I was having. So I thought I'd drop this here in case anyone else can benefit.
  2. n99hockey

    n99hockey Moderator Staff Member

    Joined:
    Feb 7, 2007
    Messages:
    57,525
    Likes Received:
    15
    thanks for that info!
    welcome to eWM

Share This Page